DDoS affecting connectivity for some customers
Incident Report for Squarespace
Resolved
Connectivity is normal for all customers.
Posted Nov 17, 2017 - 07:34 EST
Identified
A DDoS attack is causing connectivity issues for some customers.
Posted Nov 17, 2017 - 07:20 EST