Slow Processing of G-Suite Subscriptions
Incident Report for Squarespace
Resolved
We've confirmed that G Suite subscription processing has returned to normal.
Posted Jun 06, 2020 - 01:05 EDT
Monitoring
A fix has been deployed. We are continuing to monitor as subscription times return to normal.
Posted Jun 06, 2020 - 00:31 EDT
Identified
We’ve identified the root cause of the long registration times and are working on applying a fix.
Posted Jun 05, 2020 - 20:44 EDT
Investigating
We are currently investigating an issue causing slow registration times with G-Suite subscriptions.
Posted Jun 05, 2020 - 19:39 EDT
This incident affected: Google Workspace.