Domain registration, update and transfer
Incident Report for Squarespace
Resolved
This incident has been resolved.
Posted Feb 07, 2019 - 17:14 EST
Update
Registrations and transfers may take longer than normal.
Posted Feb 07, 2019 - 15:39 EST
Identified
Customers are unable to register, update or transfer domains. Our registrar is investigating the issue.
Posted Feb 07, 2019 - 14:33 EST
This incident affected: Domains.