Help Site Availability
Incident Report for Squarespace
Resolved
The issues with our help site provider should now be resolved.
Posted Mar 15, 2017 - 20:19 EDT
Identified
A service disruption with our help site provider is causing loading issues with our help site and email and chat support tools. If you are unable to open a chat or support ticket, you can reach us at customercare@squarespace.com. We apologize for the delay in responding to inquiries while we are impacted by these issues.
Posted Mar 15, 2017 - 16:57 EDT