3rd-party DNS provider service outage
Incident Report for Squarespace
Resolved
This incident is now resolved.
Posted Mar 24, 2017 - 16:04 EDT
Monitoring
Our 3rd-party DNS provider for Squarespace customer domains is experiencing an intermittent service outage. We are currently monitoring the issue.
Posted Mar 24, 2017 - 15:33 EDT